2.画面の構成、および、大まかな使い方


できるだけ使いやすく作ったつもりですが、理解しづらい部分もあります。

細かい話は後にして、大まかに感覚的に慣れてしまうといいです。



・画面の構成

起動すると、3個のウィンドウが表示されます。

<メインウィンドウ> 真ん中

奥から表側に向かって、背景、点、線の3層構造
<プレビューウィンドウ> 左側 <操作パネル> 右側

サイズ変更でプレビューのサイズも変わる

タブで機能(モード)を切り替える

サブウィンドウの表示切り替え。
 メニュー[表示]-[操作パネル]
 メニュー[表示]-[プレビュー]

ウィンドウ位置の調整。
 メニュー[表示]-[フレーム調節]



操作は機能(モード)を切り替えながら行います。
切り替えにはショートカットを使うのが便利です。

線描画モード(Play用) 点配置モード(Edit用1) グループ設定モード(Edit用2)
 メニュー[編集]-[線描画]
 ショートカット:F2

 メニュー[編集]-[点配置]
 ショートカット:F3

 メニュー[編集]-[グループ設定]
 ショートカット:F4

解くときに使う
・線に関する操作が全て可能

・点、グループの操作は基本的に不可
(キーボードからのショートカット操作のみ可)
問題作成に使う
・点(と番号)の操作が全て可能

・グループの操作は基本的に不可
(キーボードからのショートカット操作のみ可)
問題作成に使う
・グループの操作が全て可能

・点は、基本的に移動と選択のみ可能
(キーボードからのショートカット操作も可)
Tips
問題作成時の下絵に使うといい

Tips
マウスの誤操作をしやすいので注意
(ドラッグのつもりがクリックになったり)
Tips
点を配置し終えた後、位置調整するのにいい
(点の誤配置を防げ、グループ変更も楽)



・大まかな使い方

<市販の問題を入力する>
1.スキャナから問題を画像として取り込む
2.その画像を背景として読み込む
3.画像に合わせ点を配置する
4.背景を削除(もしくは新たに指定)して完成

<問題を自作する(既存の画像を参考にする)>
1.参考にしたい画像を背景として読み込む
2.画像に合わせ適宜点を配置する。
3.背景を削除(もしくは新たに指定)して完成

<問題を自作する(自分で線画を描く)>
1.線描画モードで問題にする絵を描く
2.絵の線に合わせ適宜点を配置する。
3.線画を削除して完成(必要なら背景を指定)


完成後は以下のような活用が考えられます。
・印刷して解く
・画像保存してネット上に載せる
・実行ファイルに出力して配布する
・パズル雑誌に投稿する

工夫次第でいろいろできるはずですので、適当に遊んでみてください。


戻る







補足&雑談(読まなくていいですから)

操作項目が多いので、サブウィンドウを使う形にしました。
作者的には新手法なんですが、うまくいってますかね?
まあ、こんなもんじゃないの。
各タブの中に操作方法が書いてあるのはいいかもね、分かりやすくて。
この、モード? っていうの?
後ろ二つが何だか分かんない。
端的な指摘だな。その通りではある。
使い分けをどうすりゃいいのか。
ああ、これは……実際にいじって、体で覚えてくださいという……。
言葉で説明しづらい部分ってあるんですよ。
そりゃまあ、そうだけど。
……この仕様は、作者オリジナル?
Yes! 完全に自己流です。
ネット検索で「点つなぎ」の編集ソフトは見つけられなかったし。
既にあれば、自分で作る必要ないもんな。
わざわざご苦労なことだ。
最初、必要な機能が分からないんですよね。
まず自分自身が「点つなぎ」を作る立場にならないと。
あぁ! 本屋で「点つなぎ」の本を必死にあさってる不審者がいたけど、あれ作者?
プログラム作るのも大変なんだね。
そんなにか。
そこまでして……
ええ……まあ、どう作るかが分からないと編集ソフトも作れませんから。
使いやすくて便利なソフトにしたいという一心ですね。
で、想定した使い方が最後にあるやつね。
実際、どんな作り方してるのかなあ。
直接聞けないから、分からないね。
このソフトの仕様でいいんだろうか、と作者が。
ニコリ(作者が投稿しているパズル雑誌)の人に聞いてみたら?
集まりに参加する機会もあるんでしょ。
あー。

あー。



戻る